Sophos – Solved problem with connected computer not showing as connected

I have a problem with clone computers that installed with Sophos.

As you can see below, the clone computers will show as unmanaged computer.

After I check on by one, the fact is the computer was connected and updated from Sophos server but Still show as unmanaged on console.

After do some googling I found this article and I found one registry that represent the hostname (like picture below)

And do below procedure to solved the issues

  1. Go to HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Sophos\Messaging System\Router
  2. Edit the registry key NotifyClientUpdate, with correct hostname
  3. And then update the sophos using update now button.
  4. Check into the Sophos server console and you will find the computers not shown as unmanaged again.

2 thoughts on “Sophos – Solved problem with connected computer not showing as connected

  1. note to my self :
    Before update the client name on registry delete below registry key and then restart the sophos message router services

    The Sophos Message Router has a valid certificate:
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Sophos\Messaging System\Router\Private\pkc
    and
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Sophos\Messaging System\Router\Private\pkp

    Note: if you delete these 2 keys on the client (don’t on the server😀 ) and restart the router, the client will re-request new certificates. You could try that, this would indicate much of RMS is working.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s